Problems activating your account? Send notification email to: admin@post4vps.com
Host4Fun Budget VPS Hosting
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Change hostname error
#1
Hello guys
While setting the hostname, i.e., on issuing: 

hostnamectl set-hostname example.com 

it says: 
Could not set property: Message recipient disconnected from message bus without replying

and on running: 

systemctl status systemd-hostnamed

I got this in the logs:

Dec 07 05:56:04 kvm-Post4VPS-Atlanta systemd-hostnamed[16352]: Failed to read hostname and machine information: Permi...nied
which I feel is basically 'Permission denied'. 

Never experienced this when my VPS was on OVZ...Could anyone help me? Thanks in advance.

Regards,
Sayan Bhattacharyya,

Heartiest thanks to Post4VPS and Virmach for my wonderful VPS 9!
#2
Could you try to run the command below and after that try again to set your hostname.

restorecon /etc/machine-info

What is restorecon: https://linux.die.net/man/8/restorecon

Report back please.
#3
When I run that command, this is what I get -

Quote:[root@kvm-Post4VPS-Atlanta ~]# restorecon /etc/machine-info
restorecon: lstat(/etc/machine-info) failed: No such file or directory

Thanks for the quick reply.

Regards,
Sayan Bhattacharyya,

Heartiest thanks to Post4VPS and Virmach for my wonderful VPS 9!
#4
Looks to be like a systemd bug that basically affects various distributions using systemd (RHEL, CentOS, ArchLinux, etc...).

Take a look at this bug report on RHEL: https://bugzilla.redhat.com/show_bug.cgi?id=1501193

Exactly the same issue. I'm not entirely sure but you could try the attempt fix at comment 12: https://bugzilla.redhat.com/show_bug.cgi?id=1501193#c12

Alternatively if you want I can take a look. Shoot me a PM.


After getting access to the VPS I looked into the issue and it looks like SELinux was the issue. It wouldn't allow to change the hostname. When I disabled it temporarily I could change the hostname. After a reboot I tried again and got the same error. I disabled it permanently by setting SELINUX to disabled in /etc/selinux/config.

The hostname can now be changed properly without any errors.
#5
Well this guy is the real problem solver. Amazing work. He magically fixed my VPS when I was confused on even how to proceed. Thanks a ton @Hidden Refuge. Your help is much appreciated.

Also, as he's posted the fix it'll help anyone facing the same problem in the future.

Thanks again HR. Big Grin

Regards,
Sayan Bhattacharyya,

Heartiest thanks to Post4VPS and Virmach for my wonderful VPS 9!
#6
Agreed with @sohamb03  I also think this should be stickied for future use by other mortals like me. Wink
Terminal
Thank you to Post4VPS and VirMach for my VPS 9!  I'm finally up and running again after the upgrade to KVM.
 


Possibly Related Threads...
Thread Author Replies Views Last Post
  CyberPanel Installing Error huuthi95 8 157 02-13-2020, 09:50 AM
Last Post: deanhills
  error when run vncserver hamed 6 295 11-07-2019, 04:04 PM
Last Post: deanhills
  OpenVPN Error sagher 11 1,119 04-16-2019, 06:50 AM
Last Post: Hidden Refuge
  apt-get update error sagher 7 1,013 04-02-2019, 11:45 AM
Last Post: sagher
  Error While Update VPS sagher 9 1,512 08-10-2018, 11:41 AM
Last Post: sagher

Forum Jump:


Users browsing this thread: 1 Guest(s)
Hostlease

Sponsors: VirMach - Host4Fun - CubeData - Evolution-Host - HostDare - SSDBlaze - Abc-Hosters - Hyper Expert - Shadow Hosting - Bladenode - Hostlease


About Post4VPS

Post4VPS is a forum/destiny where you can Delploy Your Free VPSs just by the Power of Posts.

We Provide VPSs of many locations like Germany,US,Canada,France,London,etc.

We also Provide VPSs of Both Linux and Windows OS.