Problems activating your account? Send notification email to: admin@post4vps.com
Host4Fun Budget VPS Hosting
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Database Problems
#1
Hello friends, 
                       I am trying to install a SMF forum on VPS running Debian ( apache2.php7.0,phpmyadmin,mysql-server ).I created a new database and installed the SMF.Whenever i visit my site it shows 
" Table 'smf.smf_messages' doesn't exist "
What should i do? Should i manually create this table or should find a proper method to fix this so it may not happen again in future installations.
Reply
#2
Make sure the SMF setup is using the correct database on the server. Check if the table exists in the database that your SMF installation is using. Sounds like something went wrong during installation and the database structure and default data for SMF wasn't installed properly.

Perhaps reinstalling SMF might help (into a new and empty database).
With best regards
Hidden Refuge
IT specialist for system integration



Friedrich Nietzsche Wrote:The advantage of a bad memory is that one enjoys several times the same good things for the first time.
Reply
#3
(05-14-2019, 09:43 AM)Rehan Wrote:  Hello friends, 
                       I am trying to install a SMF forum on VPS running Debian ( apache2.php7.0,phpmyadmin,mysql-server ).I created a new database and installed the SMF.Whenever i visit my site it shows 
" Table 'smf.smf_messages' doesn't exist "
What should i do? Should i manually create this table or should find a proper method to fix this so it may not happen again in future installations.

try reinstalling it again . " Table 'smf.smf_messages' doesn't exist " mean than when the CMS is try to open that specific table "smf_messages" it doesnt found it . the table probably doesnt exist on the mysql database you can check it on phpmyadmin
Terminal
humanpuff69@FPAX:~$ Thanks To Shadow Hosting And Post4VPS for VPS 5
Reply
#4
(05-14-2019, 11:40 AM)Hidden Refuge Wrote:  Make sure the SMF setup is using the correct database on the server. Check if the table exists in the database that your SMF installation is using. Sounds like something went wrong during installation and the database structure and default data for SMF wasn't installed properly.

Perhaps reinstalling SMF might help (into a new and empty database).

During new installations it shows the error

"

Your settings have now been saved and the database has been populated with all the data required to get your forum up and running. Summary of population:
  • Created 62 tables.
  • Inserted 777 rows.
Some of the queries were not executed properly. This could be caused by an unsupported (development or old) version of your database software.

Technical information about the queries:
  • Line #1338:
  • Line #1346:
Click "Continue" to progress to the admin account creation page.

"
Reply
#5
So, I was right about that the database structure and default data is not being installed properly during the SMF setup.

Which MySQL server version are you running? Perhaps SMF doesn't support the MySQL version you are running (too old or too new maybe).

You can use the command below to get the version information or use a tool like phpMyAdmin / Adminer:
mysql --version

Example output:
mysql  Ver 15.1 Distrib 10.1.38-MariaDB, for debian-linux-gnu (x86_64) using readline 5.28


Perhaps also the database engine is not supported.


Look what I found: https://www.simplemachines.org/community...c=560047.0 and https://www.simplemachines.org/community...c=555076.0

You said you were using Debian with quite recent software (kinda). That could mean that your MySQL server is most likely MariaDB instead of the Oracle MySQL server.

Seems like SMF isn't compatible to MariaDB MySQL or your configuration causes some issues. The second topic hints that you might have to change the default MySQL database engine.

Can you post your my.cnf file?
With best regards
Hidden Refuge
IT specialist for system integration



Friedrich Nietzsche Wrote:The advantage of a bad memory is that one enjoys several times the same good things for the first time.
Reply
#6
(05-14-2019, 04:44 PM)Hidden Refuge Wrote:  So, I was right about that the database structure and default data is not being installed properly during the SMF setup.

Which MySQL server version are you running? Perhaps SMF doesn't support the MySQL version you are running (too old or too new maybe).

You can use the command below to get the version information or use a tool like phpMyAdmin / Adminer:
mysql --version

Example output:
mysql  Ver 15.1 Distrib 10.1.38-MariaDB, for debian-linux-gnu (x86_64) using readline 5.28


Perhaps also the database engine is not supported.


Look what I found: https://www.simplemachines.org/community...c=560047.0 and https://www.simplemachines.org/community...c=555076.0

You said you were using Debian with quite recent software (kinda). That could mean that your MySQL server is most likely MariaDB instead of the Oracle MySQL server.

Seems like SMF isn't compatible to MariaDB MySQL or your configuration causes some issues. The second topic hints that you might have to change the default MySQL database engine.

Can you post your my.cnf file?


I got the output same as you used as example. and i searched for my.cnf and found 3 files.I know we need only mysql cnf files btw i have posted all of those Big Grin

Here are these 

/etc/mysql//my.cnf
# The MariaDB configuration file
#
# The MariaDB/MySQL tools read configuration files in the following order:
# 1. "/etc/mysql/mariadb.cnf" (this file) to set global defaults,
# 2. "/etc/mysql/conf.d/*.cnf" to set global options.
# 3. "/etc/mysql/mariadb.conf.d/*.cnf" to set MariaDB-only options.
# 4. "~/.my.cnf" to set user-specific options.
#
# If the same option is defined multiple times, the last one will apply.
#
# One can use all long options that the program supports.
# Run program with --help to get a list of available options and with
# --print-defaults to see which it would actually understand and use.

#
# This group is read both both by the client and the server
# use it for options that affect everything
#
[client-server]
/etc/alternatives/my.cnf
# The MariaDB configuration file
#
# The MariaDB/MySQL tools read configuration files in the following order:
# 1. "/etc/mysql/mariadb.cnf" (this file) to set global defaults,
# 2. "/etc/mysql/conf.d/*.cnf" to set global options.
# 3. "/etc/mysql/mariadb.conf.d/*.cnf" to set MariaDB-only options.
# 4. "~/.my.cnf" to set user-specific options.
#
# If the same option is defined multiple times, the last one will apply.
#
# One can use all long options that the program supports.
# Run program with --help to get a list of available options and with
# --print-defaults to see which it would actually understand and use.

#
# This group is read both both by the client and the server
# use it for options that affect everything
#
[client-server]



And the third one lists them. btw here is the code
auto
/etc/mysql/my.cnf

/etc/mysql/mariadb.cnf
200
/etc/mysql/my.cnf.fallback
100
Reply
#7
Looks like the database server is pulling some more configurations from somewhere else as the one you posted don't resemble a actual my.cnf configuration with all parameters.

Can you do the following steps?

1. Backup the old my.cnf:
mv /etc/mysql/my.cnf /etc/mysql/my.cnf.backup

2. Install new my.cnf:
wget -O /etc/mysql/my.cnf https://raw.githubusercontent.com/hidden-refuge/demp-deb9-testing/master/my.cnf

3. Restart MariaDB:
systemctl restart mariadb
or
systemctl restart mysql

4. Try to install SMF again into a brand new database.

Report back please. If that doesn't cut it you might have to modify the script that creates the tables during installation like the person did in the second thread that I linked in my previous reply.
With best regards
Hidden Refuge
IT specialist for system integration



Friedrich Nietzsche Wrote:The advantage of a bad memory is that one enjoys several times the same good things for the first time.
Reply
#8
@Hidden Refuge i have updated that my.cnf with your given method it is showing

" !Critical Error!
The installer was unable to detect any database support in PHP. Please ask your host to ensure that PHP was compiled with the desired database, or that the proper extension is being loaded. "

I think i made something wrong during php updates.Let me check again if i find any solution.

The problem has been solved by the method @Hidden Refuge.First error was due to the cnf file and it was solved by replacing the old cnf with a new one ( provided by HR ).The second issue was due to the php updates.I have purged old one and installed new.Now everything is working well.
Reply
 


Possibly Related Threads...
Thread Author Replies Views Last Post
  Database Import Error Rehan 3 311 02-05-2019, 04:57 PM
Last Post: deanhills

Forum Jump:


Users browsing this thread: 1 Guest(s)

Sponsors: VirMach - Host4Fun - CubeData - Evolution-Host - HostDare - SSDBlaze - VPSlices - Abc-Hosters - Hyper Expert - Shadow Hosting - Bladenode - HostDoc - Hostlease


About Post4VPS

Post4VPS is a forum/destiny where you can Delploy Your Free VPSs just by the Power of Posts.

We Provide VPSs of many locations like Germany,US,Canada,France,London,etc.

We also Provide VPSs of Both Linux and Windows OS.