Problems activating your account? Send notification email to: admin@post4vps.com
Host4Fun Budget VPS Hosting
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Iptables
#1
first i will talk about my issue, and may you guys figure it out with me about a solution, i setup two servers this night after some hours i checked the panel servers seems working well, but i tried to connect to them in game i find them offline, i restart one of them, and checked the game again, the two servers seems to be online, idk how maybe restarting one of them it will turn off firewalls or something idk i just tell the story and what you guys can suggest me for a quick solution about it.
[Image: lKCsllx.png]
i though doing Open incoming TCP port 27000:27999 to any source IP address: would be the solution.
suggest me people.
Thanks to Post4VPS and Host4Fun for my amazing VPS 1 
#2
I have a bit of free time left for today. Feel free to send me a private message with access details for the VPS so I can look into it.

I would require the access details:
- IP
- SSH port
- username for user that runs the game server
- root access (possible to reconfigure the firewall or install packages if needed)
- password

I cannot promise much but I can atleast took a look at it.

I would like to present a few things I have found so far below.

  1. Your current iptables firewall setup is already set to be wide open. Its default policies are set to ACCEPT. Therefore no additional rules are required to open any port(s) or allow any connection(s) to the server(s).
  2. The iptables rules you added were unfortunately setup a bit wrong and would have little to no positive effect to the situation.
  3. I have stopped OGP and started the game servers from the command line to see its output. The console output was not free of errors. Missing files mostly due to steamcmd not being properly installed. If fixed that.

Errors:
Quote:dlopen failed trying to load:
/root/.steam/sdk32/steamclient.so
with error:
/root/.steam/sdk32/steamclient.so: cannot open shared object file: No such file or directory


Fixed by installing steamcmd at /root and creating a symbolic link for the files that were not found at the requires location.

Fix (path depends on installation path of steamcmd):
ln -s /root/linux32/ /root/.steam/sdk32


Other errors:
Quote:couldn't exec listip.cfg
couldn't exec banned.cfg

Fix:
touch listip.cfg
touch banned.cfg


Still no success though at this point.

I noticed that the game servers used by OGP were from 2013! At least the build of the server files were so old according to the information on the server startup. The latest files are from 2019!

So I went and installed a fresh and new copy of Counter-Strike 1.6 server files in /root/cstest.

After fixing the errors from "Other errors" I could connect to it.

The lesson so far: the OGP game servers files are not working properly. Something is wrong! A fresh copy works.


I can connect to the OGP game server using a legit Counter-Strike 1.6 version that I own on Steam.

So something is certainly wrong with the game server or the game version you're using.

The firewall is not the problem.
With best regards
Hidden Refuge
#3
@[b]Hidden Refuge [/b]to let you know i used OGP like 5 years ago, for cs 1.6 and i had no issue that steamcmd we just ignore it it has no relation to the blocking firewall.
i didn't try 1 VPS, i used to use a lot in the past, and this is the first time that i has such an issue.
the consultation is after a server start the VPS will block players and gametrackers bot from connectioning thats why i told you, that there is an issue with the firewalls hope u understand this and figure it out. also i do share the same experience with @Rehan 
Thanks @Hidden Refuge for all you efforts to help me solve my issue but the question is from all those information the issue come from what ?
Thanks to Post4VPS and Host4Fun for my amazing VPS 1 
#4
@Hidden Refuge Thank you so much for all of your effort to investigate the matter. This is much appreciated.

In your expert opinion, does this mean that someone else with a Games Server will be able to run it successfully on VPS 1 depending on how the Games Server is set up? I.e. the issue with Games Servers not working as they should on VPS 1 has more to do with issues with the Games Server than issues with VPS 1?
[Image: 4ax8Kok.png]
Thank you to Post4VPS and VirMach for my super fast VPS 9!
- DH Blog




#5
@Hidden Refuge  Thanks for your effort. I have something to say, as I already mentioned that the game-server is only visible to one who starts it from the terminal. You should try re-checking from different place/IP. I am not sure but when i start server i can connect it easily but nobody else. During those days ( when i was trying ) server was visible to a friend once but for a short time. So i think that it is visible to only the IP who starts it. Here in Pakistan, mostly IP matches with others. Maybe that's why it was visible to him.

Thanks to Post4VPS and Sponsors for their great services.
#6
@Melvin

It is great that you have such a vast experience with Open Game Panel and Counter-Strike 1.6.

While I might have stopped playing all of these games years ago I used to host game servers myself for Counter-Strike 1.6, Counter-Strike: Source, Garry's Mod, Team Fortress 2 and even Counter-Strike: Global Offensive since 2009 for many communities I have worked with / for. I made countless tutorials for game server setups for various games on the Internet.

You always think that you know everything when doing this for years? And that's the first mistake. You never stop learning. There are many things that can hinder the game server from working properly. Addons can cause issues, misconfigurations can lead to problems and etc. Metamod, despite its age, can sometimes be really unstable together with AMXMOD (Metamod-p ftw). Dproto development stopped in 2017.

If all of this you can account for that it works properly then you can end the day with a smile on your face and be proud. If on the next day, despite no visible issues, things stop working then there is maybe something else that is wrong. That something else might be out of your control.


I understand that you might think that all the little errors play no role. My experience is different. The steamcmd errors due to missing files might not be an issue with Counter-Strike 1.6 but with other game servers. I have been using steamcmd when it was in beta and HLDS was still a thing. Even afterwards when HLDS was deprecated and steamcmd became the king there have been issues with those small errors.

When I setup a fresh copy of Counter-Strike 1.6 game server files from steamcmd I couldn't connect initially, too. For a fraction of a second I was stunned but then I saw the two errors about the missing files "listip.cfg" and "banned.cfg". I stopped the game server, created the files, started the game server again and could immediately without any issues.

So no matter how unimportant some errors might be, you might still want to look into them. A few unimportant missing files can make all the difference.


You should end your obessions towards the firewall of your VPS. There is no issue with the firewall. It is a wide open gate as it has been setup so by default on OpenVZ with all policies being set to ACCEPT --> allowing all connections to go in / out. I have two officially certified work degrees in IT: Information Technology Assistant and IT Specialist for system integration. Especially the second degree is deeply connected to networking, firewalling and etc.

So when I tell you that the firewall of your VPS is no issue you can believe it. If you choose not to... so it be. You're out of luck. I know how iptables works.

Remember Host4Fun is using OVH... blackbox DDoS protection. You never really know how it works. UDP traffic that the game servers are based on is especially a problem for DDoS protection.

All of the time you keep blaming iptables... could be simply OVH DDoS protection playing a fool or some issue with the OVH network.


@deanhills

I cannot fully rule out other issues. To do that you need time and you have to experiment with different setup of the game servers. You also need to do a lot of testing with other people from different part of the worlds.

Like I said before there might be issues that don't seem so important but are actually the big fool that breaks everything. Or it's simply out of our control.


@Rehan

Well, for all it is worth. These things usually don't make any sense. However if there is an issue at hand it might cause the game server to go down after a certain time despite Open Game Panel saying it is up and running or even the console saying it is running.


As I mentioned before. I guess you either live with it or get another VPS and try it there. I have nothing more to add to all of this.
With best regards
Hidden Refuge
#7
unfortunately there is no solution yet, what i going to do waiting for the next giveaway so VPS 1 ain't suggestible for gaming servers hope Developers would mention that in the next updates, so people won't spend time on nothing.
Thanks to Post4VPS and Host4Fun for my amazing VPS 1 
#8
(07-28-2019, 07:33 PM)Melvin Wrote:  unfortunately there is no solution yet, what i going to do waiting for the next giveaway so VPS 1 ain't suggestible for gaming servers hope Developers would mention that in the next updates, so people won't spend time on nothing.

from last announcement . Vps 1 have some problem with game server and that isnt because they try to block it , they never tried to block game server but some issue cause vps 1 to not work with some game server in some situation
Terminal
humanpuff69@FPAX:~$ Thanks To Shadow Hosting And Post4VPS for VPS 5
 


Possibly Related Threads...
Thread Author Replies Views Last Post
  iptables problem solving chanalku91 8 235 07-28-2019, 03:51 AM
Last Post: deanhills
  Iptables configuration Melvin 13 582 05-21-2019, 05:13 AM
Last Post: Hidden Refuge

Forum Jump:


Users browsing this thread: 1 Guest(s)

Sponsors: VirMach - Host4Fun - CubeData - Evolution-Host - HostDare - SSDBlaze - VPSlices - Abc-Hosters - Hyper Expert - Shadow Hosting - Bladenode - HostDoc - Hostlease


About Post4VPS

Post4VPS is a forum/destiny where you can Delploy Your Free VPSs just by the Power of Posts.

We Provide VPSs of many locations like Germany,US,Canada,France,London,etc.

We also Provide VPSs of Both Linux and Windows OS.