Problems activating your account? Send notification email to: admin@post4vps.com
Host4Fun Budget VPS Hosting

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Need Support
#1
Hello admins:

I need your help. whenever i try to update me vps with "apt-get update" command it's stuck like this.
Quote:root@xxxxxx:~# apt-get update
Ign:1 http://archive.ubuntu.com/ubuntu trusty InRelease
Hit:2 http://archive.ubuntu.com/ubuntu trusty Release
Ign:3 https://packages.sury.org/php jessie InRelease
Ign:5 https://packages.sury.org/php jessie Release
Ign:6 https://packages.sury.org/php jessie/main all Packages
Ign:7 https://packages.sury.org/php jessie/main amd64 Packages
Ign:8 https://packages.sury.org/php jessie/main Translation-en
Ign:6 https://packages.sury.org/php jessie/main all Packages
Ign:7 https://packages.sury.org/php jessie/main amd64 Packages
Ign:8 https://packages.sury.org/php jessie/main Translation-en
Ign:6 https://packages.sury.org/php jessie/main all Packages
Ign:7 https://packages.sury.org/php jessie/main amd64 Packages
Ign:8 https://packages.sury.org/php jessie/main Translation-en
Ign:6 https://packages.sury.org/php jessie/main all Packages
Ign:7 https://packages.sury.org/php jessie/main amd64 Packages
17% [Working]

and stuck more then hours. kindly give me solution.

Added quotation tags - @sagher - please remember to add quotes when the content is not personally written by you.  And copied and pasted. @deanhills

Heart LOVE FOR ALL  HATRED FOR NONE Heart
#2
I recommend to
Reconnect and try again!
It can happen because your connection is disconnected from the server
Terminal
Working On: LynaMC 3.0 ( SNAPSHOT )
#3
Try to clean the local repo storage with:
apt-get clean all

After that try to run the update again.

Alternatively you might have to switch mirrors for that sury.org PHP repo.
Kind regards
Hidden Refuge
#4
i reboot vps and run clean command. after then again repeat update command. now got this at the end

Quote:root@xxxxxxxxxx:~# apt-get clean all
root@xxxxxxxxxx:~# apt-get update
Hit:1 http://deb.debian.org/debian testing InRelease
Hit:2 http://deb.debian.org/debian testing-updates InRelease
Ign:3 https://packages.sury.org/php stretch InRelease
Hit:4 http://deb.debian.org/debian-security testing/updates InRelease
Ign:5 https://packages.sury.org/php stretch Release
Ign:6 https://packages.sury.org/php stretch/main amd64 Packages
Ign:7 https://packages.sury.org/php stretch/main all Packages
Ign:8 https://packages.sury.org/php stretch/main Translation-en
Ign:6 https://packages.sury.org/php stretch/main amd64 Packages
Ign:7 https://packages.sury.org/php stretch/main all Packages
Ign:8 https://packages.sury.org/php stretch/main Translation-en
Ign:6 https://packages.sury.org/php stretch/main amd64 Packages
Ign:7 https://packages.sury.org/php stretch/main all Packages
Ign:8 https://packages.sury.org/php stretch/main Translation-en
Ign:6 https://packages.sury.org/php stretch/main amd64 Packages
Ign:7 https://packages.sury.org/php stretch/main all Packages
Ign:8 https://packages.sury.org/php stretch/main Translation-en
Ign:6 https://packages.sury.org/php stretch/main amd64 Packages
Ign:7 https://packages.sury.org/php stretch/main all Packages
Ign:8 https://packages.sury.org/php stretch/main Translation-en
Err:6 https://packages.sury.org/php stretch/main amd64 Packages
 The HTTP server sent an invalid reply header
Ign:7 https://packages.sury.org/php stretch/main all Packages
Ign:8 https://packages.sury.org/php stretch/main Translation-en
Reading package lists... Done
W: The repository 'https://packages.sury.org/php stretch Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: Failed to fetch https://packages.sury.org/php/dists/stre...4/Packages  The HTTP server sent an invalid reply header
E: Some index files failed to download. They have been ignored, or old ones used instead.


@Hidden Refuge

_____________________________________________________________

Added quotation tags - @sagher - please remember to add quotes when the content is not personally written by you.  And copied and pasted. @deanhills

Heart LOVE FOR ALL  HATRED FOR NONE Heart
#5
I earlier had this issue too. But you can refer to this answer for a possible solution to your problem because this helped me. Maybe it would help you too?
Additionally, here is what I did(with reference to the above-mentioned answer).

I copied old source.list to '/' directory as a backup.
sudo cp /etc/apt/sources.list ~/

Now downloading new source.list and directly making it edited to original file.
sudo wget "http://pastebin.com/raw.php?i=uzhrtg5M" -O /etc/apt/sources.list

Now updating with new lists.
sudo apt-get update

Removing extras which had an impact/conflict with another file of the same, so we removed it to avoid the error.
sudo rm /etc/apt/sources.list.d/ubuntu-extras.list


Now updating again for the last time.
sudo apt-get update


This should work as it did for me. 
Credits are mentioned.
#6
(03-06-2019, 05:42 PM)Manal Wrote:  I earlier had this issue too. But you can refer to this answer for a possible solution to your problem because this helped me. Maybe it would help you too?
Additionally, here is what I did(with reference to the above-mentioned answer).

I copied old source.list to '/' directory as a backup.
sudo cp /etc/apt/sources.list ~/

Now downloading new source.list and directly making it edited to original file.
sudo wget "http://pastebin.com/raw.php?i=uzhrtg5M" -O /etc/apt/sources.list

Now updating with new lists.
sudo apt-get update

Removing extras which had an impact/conflict with another file of the same, so we removed it to avoid the error.
sudo rm /etc/apt/sources.list.d/ubuntu-extras.list


Now updating again for the last time.
sudo apt-get update


This should work as it did for me. 
Credits are mentioned.

First is i have Debian 9. and i already done it. i update my source.list i ll paste here.

Quote:deb http://deb.debian.org/debian/ testing main contrib non-free
deb-src http://deb.debian.org/debian/ testing main contrib non-free

deb http://deb.debian.org/debian/ testing-updates main contrib non-free
deb-src http://deb.debian.org/debian/ testing-updates main contrib non-free

deb http://deb.debian.org/debian-security testing/updates main
deb-src http://deb.debian.org/debian-security testing/updates main

i got it recently from debian source.list generator.
debian 9 release is " testing/unstable" Sid

Added quotation tags - @sagher - please remember to add quotes when the content is not personally written by you.  And copied and pasted. @deanhills

Heart LOVE FOR ALL  HATRED FOR NONE Heart
#7
Try these:
apt-get -y install apt-transport-https lsb-release ca-certificates
wget -O /etc/apt/trusted.gpg.d/php.gpg https://packages.sury.org/php/apt.gpg
apt-get update
Kind regards
Hidden Refuge
#8
(03-06-2019, 08:01 PM)Hidden Refuge Wrote:  Try these:
apt-get -y install apt-transport-https lsb-release ca-certificates
wget -O /etc/apt/trusted.gpg.d/php.gpg https://packages.sury.org/php/apt.gpg
apt-get update
I got this in result.

Quote:root@xxxxxxxxx:~# apt-get -y install apt-transport-https lsb-release ca-certificates
Reading package lists... Done
Building dependency tree
Reading state information... Done
lsb-release is already the newest version (10.2018112800).
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 apt-transport-https : Depends: apt (>= 1.5~alpha4) but 1.4.8 is to be installed
 ca-certificates : Depends: openssl (>= 1.1.1) but 1.1.0f-3+deb9u2 is to be installed
E: Unable to correct problems, you have held broken packages.

Quote:root@xxxxxxxxxx:~# wget -O /etc/apt/trusted.gpg.d/php.gpg https://packages.sury.org/php/apt.gpg
--2019-03-07 07:41:43--  https://packages.sury.org/php/apt.gpg
Resolving packages.sury.org (packages.sury.org)... 68.70.205.4, 68.70.205.1, 68.70.205.2, ...
Connecting to packages.sury.org (packages.sury.org)|68.70.205.4|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 2239 (2.2K) [application/octet-stream]
Saving to: '/etc/apt/trusted.gpg.d/php.gpg'

/etc/apt/trusted.gp 100%[===================>]   2.19K  --.-KB/s    in 0s

2019-03-07 07:41:43 (70.6 MB/s) - '/etc/apt/trusted.gpg.d/php.gpg' saved [2239/2239]

Added quotation tags - @sagher - please remember to add quotes when the content is not personally written by you.  And copied and pasted. @deanhills

Heart LOVE FOR ALL  HATRED FOR NONE Heart
#9
To be honest. I don't know what you did on that server but there is something really seriously broken. If apt can't even install packages... I don't think you're going to solve this or anyone else here (I could dig deeper but that'd require access for me to your server and I don't really have the time).

Take backups and reinstall to a fresh system. That'd be my suggestion at this point.
Kind regards
Hidden Refuge
#10
@sagher Do you want me to reinstall your OS? Just remember you'll have to make backups of everything as it will erase the contents of the VPS.

This thread almost feels like deja vu for me. Like looks as though Ubuntu is not good with updates - you're not the only one with problems if you Google this. Do you want to change to CentOS perhaps, as I haven't had an issue ever with updating it. CentOS is very simple and easy to use for every one.
[Image: 4ax8Kok.png]

Thank you to Post4VPS and VirMach for my super fast VPS 9!
- DH Blog
 


Possibly Related Threads...
Thread Author Replies Views Last Post
  Need Fast Support | VPS 1 chanalku91 6 1,189 06-17-2018, 02:07 PM
Last Post: chanalku91
  Support Format perryoo11 1 2,488 08-12-2016, 11:39 PM
Last Post: perryoo11

Forum Jump:


Users browsing this thread: 1 Guest(s)

Sponsors: VirMach - Host4Fun - CubeData - Evolution-Host - HostDare - SSDBlaze - VPSlices - Abc-Hosters - Hyper Expert - Shadow Hosting - Bladenode - HostDoc - Hostlease


About Post4VPS

Post4VPS is a forum/destiny where you can Delploy Your Free VPSs just by the Power of Posts.

We Provide VPSs of many locations like Germany,US,Canada,France,London,etc.

We also Provide VPSs of Both Linux and Windows OS.