Problems activating your account? Send notification email to: admin@post4vps.com
Host4Fun Budget VPS Hosting

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Need Urgent Help Regarding )openVPN
#1
Hello all experts. in past i am successfully use OpenVPN in mer server. last week i do my vps reboot and make update and upgrade commands. after this when i try to connect with my VPN. it gaves me following errors. please help me what can i do.


Tue Sep 17 09:26:47 2019 OpenVPN 2.4.7 x86_64-w64-mingw32 [SSL (OpenSSL)] [LZO] [LZ4] [PKCS11] [AEAD] built on Apr 25 2019
Tue Sep 17 09:26:47 2019 Windows version 6.1 (Windows 7) 64bit
Tue Sep 17 09:26:47 2019 library versions: OpenSSL 1.1.0j  20 Nov 2018, LZO 2.10
Tue Sep 17 09:26:47 2019 MANAGEMENT: TCP Socket listening on [AF_INET]127.0.0.1:25340
Tue Sep 17 09:26:47 2019 Need hold release from management interface, waiting...
Tue Sep 17 09:26:48 2019 MANAGEMENT: Client connected from [AF_INET]127.0.0.1:25340
Tue Sep 17 09:26:48 2019 MANAGEMENT: CMD 'state on'
Tue Sep 17 09:26:48 2019 MANAGEMENT: CMD 'log all on'
Tue Sep 17 09:26:48 2019 MANAGEMENT: CMD 'echo all on'
Tue Sep 17 09:26:48 2019 MANAGEMENT: CMD 'bytecount 5'
Tue Sep 17 09:26:48 2019 MANAGEMENT: CMD 'hold off'
Tue Sep 17 09:26:48 2019 MANAGEMENT: CMD 'hold release'
Tue Sep 17 09:26:50 2019 MANAGEMENT: CMD 'password [...]'
Tue Sep 17 09:26:50 2019 Outgoing Control Channel Encryption: Cipher 'AES-256-CTR' initialized with 256 bit key
Tue Sep 17 09:26:50 2019 Outgoing Control Channel Encryption: Using 256 bit message hash 'SHA256' for HMAC authentication
Tue Sep 17 09:26:50 2019 Incoming Control Channel Encryption: Cipher 'AES-256-CTR' initialized with 256 bit key
Tue Sep 17 09:26:50 2019 Incoming Control Channel Encryption: Using 256 bit message hash 'SHA256' for HMAC authentication
Tue Sep 17 09:26:50 2019 TCP/UDP: Preserving recently used remote address: [AF_INET]104.xxx.xx.xxx:1194
Tue Sep 17 09:26:50 2019 Socket Buffers: R=[8192->8192] S=[8192->8192]
Tue Sep 17 09:26:50 2019 UDP link local: (not bound)
Tue Sep 17 09:26:50 2019 UDP link remote: [AF_INET]104.xxx.xx.xxx:1194
Tue Sep 17 09:26:50 2019 MANAGEMENT: >STATE:1568694410,WAIT,,,,,,
[color=#ff3333]Tue Sep 17 09:27:50 2019 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)[/color]
[color=#ff3333]Tue Sep 17 09:27:50 2019 TLS Error: TLS handshake failed[/color]
Tue Sep 17 09:27:50 2019 SIGUSR1[soft,tls-error] received, process restarting
Tue Sep 17 09:27:50 2019 MANAGEMENT: >STATE:1568694470,RECONNECTING,tls-error,,,,,
Tue Sep 17 09:27:50 2019 Restart pause, 5 second(s)
Tue Sep 17 09:27:55 2019 TCP/UDP: Preserving recently used remote address: [AF_INET]104.xxx.xx.xxx:1194
Tue Sep 17 09:27:55 2019 Socket Buffers: R=[8192->8192] S=[8192->8192]
Tue Sep 17 09:27:55 2019 UDP link local: (not bound)
Tue Sep 17 09:27:55 2019 UDP link remote: [AF_INET]104.xxx.xx.xxx:1194
Tue Sep 17 09:27:55 2019 MANAGEMENT: >STATE:1568694475,WAIT,,,,,,
[color=#ff3333]Tue Sep 17 09:28:56 2019 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)[/color]
[color=#ff3333]Tue Sep 17 09:28:56 2019 TLS Error: TLS handshake failed[/color]
Tue Sep 17 09:28:56 2019 SIGUSR1[soft,tls-error] received, process restarting
Tue Sep 17 09:28:56 2019 MANAGEMENT: >STATE:1568694536,RECONNECTING,tls-error,,,,,
Tue Sep 17 09:28:56 2019 Restart pause, 5 second(s)
Tue Sep 17 09:29:01 2019 TCP/UDP: Preserving recently used remote address: [AF_INET]104.xxx.xx.xxx:1194
Tue Sep 17 09:29:01 2019 Socket Buffers: R=[8192->8192] S=[8192->8192]
Tue Sep 17 09:29:01 2019 UDP link local: (not bound)
Tue Sep 17 09:29:01 2019 UDP link remote: [AF_INET]104.xxx.xx.xxx:1194
Tue Sep 17 09:29:01 2019 MANAGEMENT: >STATE:1568694541,WAIT,,,,,,

Heart LOVE FOR ALL  HATRED FOR NONE Heart
Reply
#2
Moved to VPS Support Forum.
[Image: 4ax8Kok.png]

Thank you to Post4VPS and VirMach for my super fast VPS 9!
- DH Blog
Reply
#3
I need to fix it as soon as possible.. please sort out the issue what goes wrong. even i never done any change. try many commands tutorial to fix but same result. where can i go to get exact issue.

Heart LOVE FOR ALL  HATRED FOR NONE Heart
Reply
#4
@sagher  Server 9 doesn't like updates, particularly since it's on a rapidly growing outdated kernel.  If you followed some of the discussions about OpenVZ 6 coming to an end soon, you'll have seen that information. You can read about it here:
https://post4vps.com/Thread-The-End-of-O...t4VPS-VPSs

Please note that VPS 9 is an unmanaged VPS.  So you need to figure out yourself how to fix problems that come from scripts and software you installed yourself.  We can reinstall the OS for you, but solving your OpenVPN issue is really not for us to do.
[Image: 4ax8Kok.png]

Thank you to Post4VPS and VirMach for my super fast VPS 9!
- DH Blog
Reply
#5
(09-19-2019, 03:08 AM)deanhills Wrote:  @sagher  Server 9 doesn't like updates, particularly since it's on a rapidly growing outdated kernel.  If you followed some of the discussions about OpenVZ 6 coming to an end soon, you'll have seen that information. You can read about it here:
https://post4vps.com/Thread-The-End-of-O...t4VPS-VPSs

Please note that VPS 9 is an unmanaged VPS.  So you need to figure out yourself how to fix problems that come from scripts and software you installed yourself.  We can reinstall the OS for you, but solving your OpenVPN issue is really not for us to do.

Thank you for your kind reply. but i am not willing for VPS support. thats why i choose a general Support section because i need a clue or support which only concern with OpenVPN. not for VPS-9. i know my vps is running well all other programs run fine. no issue.
the only issue is in OpenVPN. i try to remove old one and install it again i think. after that i tell you the story.
Again i mention that i am asking for 3rd party app help. not asking for VPS support.

Heart LOVE FOR ALL  HATRED FOR NONE Heart
Reply
#6
(09-19-2019, 05:39 AM)sagher Wrote:  the only issue is in OpenVPN. i try to remove old one and install it again i think. after that i tell you the story.
Again i mention that i am asking for 3rd party app help. not asking for VPS support.
I understood that from the start @sagher. But I'm not sure whether you understand that VPS 9 is on an outdated kernel. You may not be able to solve the problem. That is possibly why no one has been responding to your 3rd party support request.
[Image: 4ax8Kok.png]

Thank you to Post4VPS and VirMach for my super fast VPS 9!
- DH Blog
Reply
#7
Have you checked the OpenVPN logs on your server? Is the service even running properly? Did you modify the firewall setup to block ports and only allow certain ports? Make sure the OpenVPN server configuration is the same as you configured it. A mismatch between server and client configuration can already cause big issues.
Kind regards
Hidden Refuge
Reply
#8
(09-21-2019, 08:18 AM)Hidden Refuge Wrote:  Have you checked the OpenVPN logs on your server? Is the service even running properly? Did you modify the firewall setup to block ports and only allow certain ports? Make sure the OpenVPN server configuration is the same as you configured it. A mismatch between server and client configuration can already cause big issues.

No Sir i do nothing. i never touch IPtable or port settings. even i try after disable ufw app. but still result. i only done update command. where i found log file

Heart LOVE FOR ALL  HATRED FOR NONE Heart
Reply
#9
Linux stores logs usually in /var/log unless you have configured it otherwise. Depending on the application there might be a folder inside /var/log with the application name where the logs are stored (e.g. /var/log/openvpn) or simply a single log file where everything is stored (one example is /var/log/syslog).

I would recommend to look into OpenVPN logs if available but also syslog and other available logs. And also check journalctl and systemctl status.

Something must have happened during the update that either broke the server or changed something elsewhere.
Kind regards
Hidden Refuge
Reply
#10
It looks like tls handshake error . Make sure that the tls is configured correctly and open all the port required for the vpn . Check iptables and ufw maybe the update mess with those
Terminal
humanpuff69@FPAX:~$ Thanks To Shadow Hosting And Post4VPS for VPS 5
Reply
 


Possibly Related Threads...
Thread Author Replies Views Last Post
  OpenVPN Error sagher 11 729 04-16-2019, 06:50 AM
Last Post: Hidden Refuge

Forum Jump:


Users browsing this thread: 1 Guest(s)

Sponsors: VirMach - Host4Fun - CubeData - Evolution-Host - HostDare - SSDBlaze - VPSlices - Abc-Hosters - Hyper Expert - Shadow Hosting - Bladenode - HostDoc - Hostlease


About Post4VPS

Post4VPS is a forum/destiny where you can Delploy Your Free VPSs just by the Power of Posts.

We Provide VPSs of many locations like Germany,US,Canada,France,London,etc.

We also Provide VPSs of Both Linux and Windows OS.