Pages (3):
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post4VPS Benchmarking Script
Hello Post4VPS Community,

Ready for some exciting news? Surely you are. Well, it's a matter of great joy to announce that Post4VPS is getting its own benchmarking script! This will make it a lot easier for newbies to find everything in one place and that too on the 'Tutorials' forum. Isn't it amazing?

So without further delay, let's introduce the benchmarking script. Post4VPS Benchmarking Script v1 is an improved version of @"Hidden Refuge"'s Benchmarking Script 2.0 that can be found here. There are a lot of people who contributed to this benchmarking script previously which shall be highlighted in the credits section of my post.

Before that, let's see what's new in this version:
  • Fixed the problem with Washington DC speed test server, which wasn't allowing the script to execute completely
  • Fixed the OS display problems with CentOS 7
  • Added new speed test servers for users to analyze their VPS's performance from various parts of the world

New fixes, suggestions, improvements are always welcome. You can directly post in this thread or create an issue on GitHub. The Benchmarking Script is released under the MIT license, so anyone with a GitHub account is free to fork it and improve it further, then create a pull request.

The project on GitHub:

  • Copyright © 2019 by sohamb03 (Fixing and adding new speed test servers and fixing OS display problems)
  • Copyright © 2015 - 2017 by Hidden Refuge (Various bug fixes and performance improvements)
  • Copyright © 2011 by dmmcintyre3 (Speed Test Modification)
  • Copyright © 2011 by akamaras/camarg (Original Script)

Now coming to the execution portion of the script:


wget --no-check-certificate && bash && rm -rf

OR (if you don't have/want to download wget)

curl -O && bash && rm -rf

[NOTE: Your OS might lack trusted CA bundles so please leave --no-check-certificate there so wget can download the file without saying unknown certificate issuer. You can always check the source code on Github if you're not sure what it does.]

Various other options for running the script:

Running the script as above (Direct Run) will run the classic mode that includes the system information, the IPv4 only speed test with 15x 100 MB test files in various regions around the world and the IO test. It will use 1.5 GB of bandwidth.
  • Classic mode with IPv6 only speed test:
    ./ -6
    (This includes the system information, an IPv6 speed test that will download 10x 100 MB files from various regions around the world over IPv6 only and the IO test. This will use 1 GB of bandwidth.)

  • Dual stack speedtest:
    ./ -46
    ./bench -64
    (This includes the system information, the IPv4 and IPv6 speedtest and the IO test. 2.5 GB bandwidth will be used.)

  • System information only:
    ./ -sys
    (This will only display the system information without any speedtest and IO test.)

  • IO test only:
    ./ -io
    (This will perform the 3 run IO test and the average IO calculation only.)

  • Classic mode with system benchmark:
    ./ -b
    (Classic mode with system benchmark. This will use 1.5 GB bandwidth!)

  • IPv6 speedtest with system benchmark:
    ./ -b6
    (IPv6 only speed test with system benchmark. This will use 1 GB bandwidth!)

  • Dual stack speedtest with system benchmark:
    ./bench -b46
    ./bench -b64
    (Dual stack speed test with system benchmark. This will use 2.5 GB bandwidth.)

You can see the full result generated by the script including system information, IPv4 speedtest, and the IO test in the link below.

Demo Results:


Vote of Thanks: I'd like to express my sincere gratitude to @"Hidden Refuge" who helped me a lot in the modification of this script to what it's now. His valuable suggestions went a long way in helping users analyze their VPS's performance from different parts of the world. Also, he contributed by testing the beta script on his Debian VPS.

Thanks to @Decent12 who helped in testing this script on Ubuntu platform.

Thanks to @Dynamo, the architect of this forum, for his valuable work of creating this forum and integrating us together here in this community.

Finally, thanks to all the Post4VPS administrators and users who extended their support and encouragement that helped me a lot, especially @deanhills, @perryoo11 and all others who didn't find a mention.

NOTE: This whole thread was typed from my mobile using MyBB MyCode. As a result, errors in format might have crept in. Please feel free to report any such error here in this thread.

Sayan Bhattacharyya,

Heartiest thanks to Post4VPS and Virmach for my wonderful VPS 9!
Indeed, its helpfull if a new user wants to create a review and he dont know linux commands very well.
this thread should sticky
Thanks for your complement @kabir145. Indeed if the admins find this script good, they'll mark it important.

Well I've also something very important to update. Just noted this while experimenting with my script. For those users, who are not willing to do the direct method, and will be trying to do the individual tests, there's a good chance that you may encounter a "bash permission denied" error.

This is basically the fix for that. For those having problem with only the download, here's the command (execute in the directory you'll execute the fix also):

wget --no-check-certificate

Now for the fix, while doing this ensure, you're the root user or a user with sudo privileges.

sudo su

Then execute this in the directory you've installed the script:

bash (-sys or whatever)

Hope this will prove to be useful for many users who'll be trying out the script!

@deanhills: While reading your review if VPS 9 Pheonix, I feel this is the reason why you got the permission denied error on @"Hidden Refuge"'s Benchmark Script.

Sayan Bhattacharyya,

Heartiest thanks to Post4VPS and Virmach for my wonderful VPS 9!
A very good idea, I experimented with these scritps once and it is a very mess to find one that is working properly.

I tried to use this but unfortunately it doesn't past the CDN speed test. Maybe my VPS speeds aren't so high and it takes A LOT. I don't know.

I want to notify the users, that you will need to give the execution permission to the file after getting it via wget.

sudo chmod +x ./
Thanks to Post4VPS and Bladenodefor VPS 14
A brief and general note: If you execute the first full command provided by @sohamb03, that uses a pipe to send the script to bash for execution, you don't need to manually set permission or manually execute the script.

This has a small disadvantage though! This way you can only run the default benchmark mode (system information, IPv4 speed tests and I/O test). You cannot pass parameters to the script when piping it to bash or anything else for execution or further processing. That's why only the default mode will work as it is what is being executed when simply running the script without a parameter.

If you want to use any of the other benchmark mode you have to download the shell script to the server. Setting permission in this case is also not really necessary. Simply use your shell to run the script directly by using the command below (bash shell):
bash -<parameter>

^ This will directly run the script with the given parameter.

@sohamb03 has explained this already after I mentioned it to him in the shoutbox. Just look at this post:


I started a benchmark cycle on my Insomnia247 Shell and it works. It takes a while due to the rather slow network of the server though.

See yourself:

You probably have to wait longer. That seems to be especially the case when the server you test has a slower connection or a not so good connection to everything far outside of its location (e.g. your server is in France, Europe and has bad connectivity to US and Asia). Like in my results from above.

I and @sohamb03 have been looking through dead speed test links and replaced them all. In addition we and a few other users made several tests to make sure everything works.
[Image: zHHqO5Q.png]
I can correct myself saying that it worked. My main problem was a SLOW server that downloaded the test data with a 126kb/s speed!

Well, nice work!
Thanks to Post4VPS and Bladenodefor VPS 14
Well, @LightDestory, as HR already mentioned, I'd given the same suggestion of updating permissions before @"Hidden Refuge" corrected me, and then I updated what he had said.

Also, regarding the issue of running of this P4V Benchmark Script too, it just wouldn't run on my VPS 9 too, mainly because download speed is too poor from Europe and Asia as HR already stated. For me, it was 500 Kbps. And that's why you waited forever, in your first run.
Sayan Bhattacharyya,

Heartiest thanks to Post4VPS and Virmach for my wonderful VPS 9!
Just one thing, normally it is better to fork the original repository first and then make changes on top of it. Now although you do give credits to the past contributors, all their previous commit history are not included in your new repository.

But overall it is glad to see there is now a working script called "Post4VPS Benchmarking Script". Good job @sohamb03 Smile

I know it's been long ago that I promised to test the current version but here is the result. Everything seems to work very well. No issues or formatting mistakes. Really good job you did there with the logo!

I'm excited to see how you will solve the disk speed calculation issue when you have results in MB/s and GB/s areas together and the average value needs to be calculated properly.

Good job!
[Image: zHHqO5Q.png]
Just a heads up. The Dallas, TX, US mirror you are using seems to be no longer working like the other older mirrors that we sorted out months ago. I tested the script and it stops right after the Atlanta, GA, US speed test and what follows after that? Right, it is Dallas, TX, US! The speed test after that one works. So I just took the URL out of the script and tested it normally with wget. It gets stuck at initiating the connection to the server (like the old dead mirrors we sorted out).

Feel free to use for Dallas instead. I use this mirror on my script and it works fine so far. I ran a full cycle of my script and had no issues... which means no dead mirrors or other issues. You might also want to check your other mirrors and IPv6 mirrors.
[Image: zHHqO5Q.png]
Pages (3):

person_pin_circle Users browsing this thread: 1 Guest(s)
Sponsors: VirMach - Host4Fun - CubeData - Evolution-Host - HostDare - Hyper Expert - Shadow Hosting - Bladenode - Hostlease - RackNerd - ReadyDedis - Limitless Hosting