Problems activating your account? Send notification email to: admin@post4vps.com
Host4Fun Budget VPS Hosting
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[VPS-8]VNC Probelm
#1
Hi friends, I am a holder of VPS 8.Last night i have re-installed the OS on my VPS.Replaced Ubuntu with Debian 9.In VPS 9 root login is disabled.I want to enable root login. When i tried to login via VNC it is showing "Booting from Hard Drive".I have waited almost 30 minutes for this to get started but nothing happens.I have tried re-starting the VPS but nothing happens. I have also tried sending CtrlAltDel but it looks like button is not working

OS: Debian 9
Boot Order is ( 1st: Hard Drive 2nd: Cd Room )
VNC : HTML 5 Client SSL

https://i.imgur.com/cipOIHK.png

Thanks to Post4VPS and Sponsors for their great services.
#2
If you don't mind and if the staff doesn't mind. Feel free to send the me login details for the control panel and I will take a look.

The issue has most likely no relation to the control panel emergency VNC though. Looks like something different.
Kind regards
Hidden Refuge
#3
@Rehan. If you want @Hidden Refuge to help, please feel free to send your info to him.
[Image: 4ax8Kok.png]

Thank you to Post4VPS and VirMach for my super fast VPS 9!
- DH Blog
#4
I have sent you the panel information. Feel free to re-install if i made any mistake during the installation.
@Hidden Refuge

Thanks to Post4VPS and Sponsors for their great services.
#5
The core issue of this thread, that basically is a unresponsive provider VNC service, couldn't be solved by me unfortunately. The VNC becomes absolutely unresponsive to keyboard input once the server has booted into the installed OS. The VNC does respond to keyboard input before the OS starts booting (e.g. the virtual BIOS or a mounted OS ISO).

I tried two of three VNC versions a) the HTML5 VNC with a up to date version of Firefox and b) the normal VNC with the latest version of RealVNC VNC client. Neither worked once the OS started booting. Unfortunately Java is no longer supported in Firefox and therefore I couldn't try out the Java VNC that was also included in SolusVM. Unfortunately despite having Java 8 Update 221 installed on my system... Internet Explorer 11 as bad as it is didn't work for the Java VNC either (Java Add-Ons were both enabled).

I'm afraid that this VNC issue is out of my or the users control and might need to be looked into by the provider. I cannot 100% safely assume that it might still something that the end user could fix. Maybe a certain software package inside the OS is missing. I don't have a clue though. The last time I had a Xen (PV) VPS was back in 2013/2014 on FreeVPS.us and I never had a Xen-HVM VPS with SolusVM.


The issue related to not being able to login as root via SSH due to this feature being disabled from Debian 9 and upwards has been solved. You can read how I managed to enable root login and reset the password below.

What I did was the following:

1) I set up the boot order to boot from "CD ROM only" and mounted the Debian 9 ISO.

2) I reboot the VPS from SolusVM and connected to the VNC using the RealVNC VNC client.

3) In the boot menu of the Debian 9 ISO I opened up the advanced menu.

4) In the advanced boot menu I selected and started the rescue mode.

5) Once the rescue mode was loaded up I have set up a few basic things (language, keyboard, timezone) and then I configured the rescue mode to mount /dev/xvda1 (the partition that contains the installed Debian 9 OS) as the root / partition with a shell to run commands in.

6) Using the shell with the mounted partition I could access /etc/ssh/sshd_config with nano and set "PermitRootLogin" to "yes" from "without-password". I saved the file normally via nano afterwards.

7) I didn't know the root password so I have reset it using the normal way by simply running the "passwd" command. In rescue mode you are already a root user and when you mount the partition where the OS is and run passwd or other commands you actually change files, user passwords and etc of the installed OS on the server without being booted into that OS.

8) Once I reset the password I enter "exit" and after that I selected the option to reboot the system.

9) In SolusVM I changed the boot order to "Hard Disk Only" and unmounted the Debian 9 ISO and rebooted the VPS again.

10) I turned puTTY on, entered the IP of the server and could login with the root user and password I set during the rescue operation. Ding! I was in.


Would the VNC not work in the virtual BIOS and the mounted OS ISOs then there could have been nothing I could have done as the VNC of SolusVM is basically the only mean of emergency access. And in our case it is useless already once the installed OS has booted.
Kind regards
Hidden Refuge
#6
Bundle of Thanks @Hidden_Refuge, Everything is working fine.As you explained me everything i have decided to move to KVM and Virtualizor on next giveaway.I will try to learn everything you told until next giveaway.

Can be marked as solved.

Thanks to Post4VPS and Sponsors for their great services.
 


Forum Jump:


Users browsing this thread: 1 Guest(s)

Sponsors: VirMach - Host4Fun - CubeData - Evolution-Host - HostDare - SSDBlaze - VPSlices - Abc-Hosters - Hyper Expert - Shadow Hosting - Bladenode - HostDoc - Hostlease


About Post4VPS

Post4VPS is a forum/destiny where you can Delploy Your Free VPSs just by the Power of Posts.

We Provide VPSs of many locations like Germany,US,Canada,France,London,etc.

We also Provide VPSs of Both Linux and Windows OS.