Problems activating your account? Send notification email to: admin@post4vps.com
Host4Fun Budget VPS Hosting
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Can a ISP "null" IPs in range with FTP ports?
#1
Question 
Hi, I have a question (and a problem) - I cannot connect to my FTP provided by my VPS provider... I've tried everything, but I noticed that I can connect with my friends phone, but not mine. I cannot also connect with my computer or laptop. All of my devices are connected to the same ISP...
I'll post the ENTIRE log of what is happening when I try to connect to my FTP server.
Status: Connecting to 66.11[the rest of my ip]...
Status: Connection established, waiting for welcome message...
and that's all. Nothing else. Just "waiting for welcome message". But I can establish a connection! Just... everything seems to be "nulled"? As in the FTP is sending empty, dummy packets. My FTP server starts with "66". But, when I try connecting to my old FTP, hosted on the same VPS site, it actually works! But it starts with "192", a MUCH higher number than 66. But I can connect to it through Minecraft though (as I'm hosting a game server)! Minecraft uses a much higher port than FTP; FTP uses 21, and Minecraft uses 25565 (or similar). 
halp? Tongue

P.S: I cannot change the IP of the server as it isn't included in my hosting package (which I got for free, so fair enough).
#2
can you connect to ssh service on port 22 on that vps ?
let me guess. the answer is yes.

you can use http://portquiz.net/ to test connection to specific tcp ports. use 
cat < /dev/tcp/portquiz.net/22
 in this case. my guess is you will see you can.

I think your iptables (firewall) is not configured to let incoming on 22.

check the rules using iptables -L

let us know.
Sincere Thanks to Shadow Hosting and post4vps  for my awesome vps4. Also a big thanks to cubedata for the great experience on my previous vps, vps8.
#3
Nope, I cannot. It just gives me this:
Response: SSH-2.0-OpenSSH_6.7p1 Debian-5
Also, I cannot access my FTP on my phone... I don't know if my phone has a firewall? Also, it would be nonsensical if I could connect to a FTP server but my firewall would be blocking the FTP ports. The issue is not that I cannot connect to ANY FTP server, but that any IP starting with 66 just times out. Also, I'm not running Linux so I cannot do iptables. It just does:
'iptables' is not recognized as an internal or external command,
operable program or batch file.
So iptables is of the table (heh)... Also, the link you posted just gives me a 404 Not Found message. I tried portquiz.net:21 AND portquiz.net:22 and it gave me a ERR_UNSAFE_PORT error, but that's just a Chrome thing... I guess? "--explicitly-allowed-ports=21" makes portquiz.net:21 work, so that's why I'm guessing that Chrome is doing that.

TL;DR: I cannot connect to port 22 on that VPS, portquiz.net:21 works (if you say to chrome it is not malicious), can connect to other FTPs, even on the same VPS site, cannot do iptables as I'm on Windows and when I try to connect to a similar IP of the VPS it times out as well.
#4
why are you doing iptables on your local system ? your system can reach out to port 22 on a remote system. that remote system is failing to respond. cause of not open port 22.

portquiz.net is using port 22 for its own service. so test wont work. you will just get the info, which is nirmal.
Sincere Thanks to Shadow Hosting and post4vps  for my awesome vps4. Also a big thanks to cubedata for the great experience on my previous vps, vps8.
#5
Oh, sorry for the misunderstanding. I cannot do iptables on the VPS as I do not have access to any terminal on there, it's a gameserver and I have access to the control panel (Multicraft). Don't know why I should do iptables on the VPS (I think you want me to run iptables on the VPS? I think "remote system" is reffering to the VPS) because I can access the FTP if I change ISPs (I tried connecting on my friend's laptop and it worked, but when I try to connect on my phone/computer/laptop it just doesn't work.)
#6
oh..sorry man ! I missed the one important line. which was
"but I noticed that I can connect with my friends phone".

so it seems like your isp is at fault. by the way, can you check if your internet router is doing ok ?

is it ADSL ?

can you test ftp over a vpn ?

off to sleep..
Sincere Thanks to Shadow Hosting and post4vps  for my awesome vps4. Also a big thanks to cubedata for the great experience on my previous vps, vps8.
#7
I tried connecting through 2 proxies I found at proxydb, but to no avail -- it just times out like without a proxy. My router is doing fine, but I tried resetting the DHCP server, but it didn't do anything, only changed my IP. I don't have ADSL as I have a SIM-card inserted into my router and I have a 4G+ connection that way. By the way, my phone isn't using WiFi from my router, but it's using 3G. So... either my ISP is really disliking my VPS' FTP server or my VPS server did not like my ISP. I'm using vpscraft from VirMach, mentioning because it's a partner of post4vps so someone could have an answer. Also, tried contacting support, but from their end everything was fine. I'm starting to really hate my ISP...
#8
A proxy is, well, a proxy but not a VPN. Try a VPN. If you tried a proxy like a HTTP/HTTPS proxy then you cannot connect to FTP. You need to use a SOCKS4/5 proxy to tunnel other protocols than HTTP/HTTPS over the proxy. A VPN will tunnel all traffic through. ProtonVPN provides a fair free VPN that you could use to test.
With best regards
Hidden Refuge
 


Forum Jump:


Users browsing this thread: 1 Guest(s)

Sponsors: VirMach - Host4Fun - CubeData - Evolution-Host - HostDare - SSDBlaze - VPSlices - Abc-Hosters - Hyper Expert - Shadow Hosting - Bladenode - HostDoc - Hostlease


About Post4VPS

Post4VPS is a forum/destiny where you can Delploy Your Free VPSs just by the Power of Posts.

We Provide VPSs of many locations like Germany,US,Canada,France,London,etc.

We also Provide VPSs of Both Linux and Windows OS.