Problems activating your account? Send notification email to: admin@post4vps.com
Host4Fun Budget VPS Hosting
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
error when run vncserver
#1
hello i got this error when i enter the "vncserver :1" command .
i install it without any problem but when i run it i got this error . pls help me . ty
root@arta:~# vncserver
xauth: (stdin):1:  bad display name "arta:1" in "add" command

New 'arta:1 (root)' desktop is arta:1

Starting applications specified in /root/.vnc/xstartup
Log file is /root/.vnc/arta:1.log
Thanks Post4Vps And Host4Fun For KVM VPS
Reply
#2
Your error logs seems to point out that there is a invalid entry on the 'add' command.

We need more details about your configuration and if you can a dump of your configuration.

Did you follow @Hidden Refuge tutorial?
Thanks to Post4VPS and VirMach for VPS 9 - Buffalo!
Reply
#3
(11-06-2019, 07:55 PM)LightDestory Wrote:  Your error logs seems to point out that there is a invalid entry on the 'add' command.

We need more details about your configuration and if you can a dump of your configuration.

Did you follow @Hidden Refuge tutorial?

I did not do anything .
I was using vnc 1 month ago through this same configuration and had no problems.
How did this problem come about now?
Error is not obvious at all I don't know what to do if you know what to tell me.

this is log file and log file error's ...
Xvnc Free Edition 4.1.1 - built Feb 25 2015 23:02:21
Copyright (C) 2002-2005 RealVNC Ltd.
See http://www.realvnc.com for information on VNC.
Underlying X server release 40300000, The XFree86 Project, Inc


Wed Nov  6 13:31:43 2019
vncext:      VNC extension running!
vncext:      Listening for VNC connections on port 5901
vncext:      created VNC server for screen 0
error opening security policy file /etc/X11/xserver/SecurityPolicy
Could not init font path element /usr/X11R6/lib/X11/fonts/Type1/, removing from list!
Could not init font path element /usr/X11R6/lib/X11/fonts/Speedo/, removing from list!
Could not init font path element /usr/X11R6/lib/X11/fonts/misc/, removing from list!
Could not init font path element /usr/X11R6/lib/X11/fonts/75dpi/, removing from list!
Could not init font path element /usr/X11R6/lib/X11/fonts/100dpi/, removing from list!
Could not init font path element /usr/share/fonts/X11/75dpi/, removing from list!
Could not init font path element /usr/share/fonts/X11/100dpi/, removing from list!

(nautilus:25135): Gtk-WARNING **: Failed to register client: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files

** (gnome-panel:25132): WARNING **: Failed to register client: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files
Window manager warning: Log level 32: could not find XKB extension.
Failed to parse arguments: Unknown option --login
Window manager warning: Missing composite extension required for compositing

(gnome-panel:25132): Gtk-CRITICAL **: gtk_widget_get_preferred_height_for_width: assertion 'width >= 0' failed

(gnome-panel:25132): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -1 and height 24

(gnome-panel:25132): Gtk-CRITICAL **: gtk_widget_get_preferred_height_for_width: assertion 'width >= 0' failed

(gnome-panel:25132): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -1 and height 24
Nautilus-Share-Message: Called "net usershare info" but it failed: Failed to execute child process "net" (No such file or directory)
Window manager warning: Log level 32: could not find XKB extension.
Window manager warning: Screen 0 on display ":1" already has a window manager; try using the --replace option to replace the current window manager.

** (gnome-settings-daemon:25133): WARNING **: Unable to register client: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files
Thanks Post4Vps And Host4Fun For KVM VPS
Reply
#4
what do you see for
vncserver --list

can try setting machine name in /etc/hosts
as
127.0.0.1 name_of_machine localhost

also try doing as follows,

sudo locale-gen
sudo localectl set-locale LANG="en_US.UTF-8"
vncserver -kill :1
vncserver

let us know what you changed in the meantime..
Sincere Thanks to Shadow Hosting and post4vps  for my awesome vps4. Also a big thanks to cubedata for the great experience on my previous vps, vps8.
Reply
#5
You asked me to look at the issue. Well, here is my though of it (I have never used VNC on any of my servers. Merely just created a guide out of a thread where a VNC issue needed to be solved). It looks like your desktop environment and window manager seems to be broken. All the errors in your log hint that it fails to create a session in the desktop environment due to several things actually missing from the system. Fonts aside there are a lot of critical error messages.

Maybe reinstalling the DE and WM will help? I have no idea. I don't have any experience with VNC.
Kind regards
Hidden Refuge
Reply
#6
(11-07-2019, 12:29 AM)rudra Wrote:  what do you see for
vncserver --list

can try setting machine name in /etc/hosts
as
127.0.0.1 name_of_machine localhost

also try doing as follows,

sudo locale-gen
sudo localectl set-locale LANG="en_US.UTF-8"
vncserver -kill :1
vncserver

let us know what you changed in the meantime..
this is hosts file 
127.0.0.1 localhost
127.0.1.1 ubuntu

# The following lines are desirable for IPv6 capable hosts
::1     localhost ip6-localhost ip6-loopback
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters

(11-07-2019, 05:47 AM)Hidden Refuge Wrote:  You asked me to look at the issue. Well, here is my though of it (I have never used VNC on any of my servers. Merely just created a guide out of a thread where a VNC issue needed to be solved). It looks like your desktop environment and window manager seems to be broken. All the errors in your log hint that it fails to create a session in the desktop environment due to several things actually missing from the system. Fonts aside there are a lot of critical error messages.

Maybe reinstalling the DE and WM will help? I have no idea. I don't have any experience with VNC.

I did, but the problem didn't work out.
Thank you for respecting my word dear friend.
Anyway thank you for your guidance. Excuse me for taking your time
Thanks Post4Vps And Host4Fun For KVM VPS
Reply
#7
Moved to VPS Support Forum.
Terminal
Thank you to Post4VPS and VirMach for my incredible VPS 9!
Reply
 


Possibly Related Threads...
Thread Author Replies Views Last Post
  OpenVPN Error sagher 11 822 04-16-2019, 06:50 AM
Last Post: Hidden Refuge
  apt-get update error sagher 7 659 04-02-2019, 11:45 AM
Last Post: sagher
  Error While Update VPS sagher 9 1,331 08-10-2018, 11:41 AM
Last Post: sagher

Forum Jump:


Users browsing this thread: 1 Guest(s)

Sponsors: VirMach - Host4Fun - CubeData - Evolution-Host - HostDare - SSDBlaze - VPSlices - Abc-Hosters - Hyper Expert - Shadow Hosting - Bladenode - HostDoc - Hostlease


About Post4VPS

Post4VPS is a forum/destiny where you can Delploy Your Free VPSs just by the Power of Posts.

We Provide VPSs of many locations like Germany,US,Canada,France,London,etc.

We also Provide VPSs of Both Linux and Windows OS.