Problems activating your account? Send notification email to: [email protected]
Host4Fun Budget VPS Hosting

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Issues with installing myvestacp
#11
(04-14-2021, 07:12 AM)Mashiro Wrote:  @sagher

The error / warning message is pretty clear (at least in my humble opinion).

The installer tries to create a Let's Encrypt TLS certificate for your server based on the hostname of your server. The hostname of or your server is however a hostname that doesn't exist as a real domain or if it exists it is not pointed to the IP address of your VPS.

The best way to fix this would be to change the hostname of your VPS to a domain that you own and that is pointed to the IP address of your VPS. Or otherwise accept that a self signed TLS certificate will be used.

Yes i got it, but my confusion is that i got free cloudflare services and register domain from freenom. so the whole story is the freenom domains are bypass with cloudflare nameservers. and after this default process my domains are unable to respond. even i try to add them into myvestacp WEB domain add option. 

So i need to know that how to compile all NS and which is the criteria to got a working Domain at the end. 

Thank you
Heart LOVE FOR ALL  HATRED FOR NONE Heart
Reply
#12
@sagher  Just so you know, myvestacp.com has a discussion forum where you can get support from the owner of the script.  I noticed there was someone else who asked your question at the Forum:
https://forum.myvestacp.com/viewtopic.php?f=14&t=189

May be a good idea to check through the topics of the Installation Discussion Forum as that way you can learn about how to set it up properly:
https://forum.myvestacp.com/viewforum.php?f=14

I also suggest  once you've made a change to the DNS or to the Host Name, to ask for a reinstallation of Debian again (in the Private Support Forum) and then reinstall the panel from scratch, otherwise maybe Lets Encrypt won't work as it should after the changes have been made.  In my experience with panels, if you get a major issue with a panel like the one above, it's always better to reinstall the OS and start the panel installation fresh after the correction has been made.

Regarding change of the host name. I also have Freenom domains.  What may help is for you to do as the instruction says.  To create an A record in Freenom Dashboard for the domain you are using with the panel.  In addition to the Cloudflare Name Servers you already have.  And see if both will work.  If not, maybe using Freenom DNS is good, as my experience with Freenom DNS has been even better than with Namecheap DNS.

As far as I can remember for you to create the A Record in your Freenom Dashboard you have to change the name servers to Freenom DNS in your Freenom Domain Dashboard first: 

1. Click on List of Domains and then Click on "Manage Domain" next to Domain Name in the list.

2. Click on "Management Tools" and select Nameservers.  Then click default name servers. You have to select on Freenom DNS for Nameservers first before you can create an A record.

3. Then click on "Manage Freenom DNS"

[Image: nNA5dRc.png]

3. Then create A record like this (name is blank - Target is the IP of your VPS):

[Image: BE9ncvQ.png]



@sagher After you've made a change in the domain host name and DNS, then make a Debian reinstallation request in Private Support Requests first and I'll reinstall Debian again, so you can start the new panel fresh with the domain host name and DNS fixed.
Terminal
Thank you to Post4VPS and VirMach for my awesome VPS 9!  
Reply
#13
After Done all settings. i am facing this issue. cannot go forward from this screen. 

   


How to get out from it. ?
Heart LOVE FOR ALL  HATRED FOR NONE Heart
Reply
#14
(04-19-2021, 09:58 AM)sagher Wrote:  After Done all settings. i am facing this issue. cannot go forward from this screen. 




How to get out from it. ?

@sagher  There isn't enough information in your inquiry to make sense for any one who isn't using the script.  It doesn't mean anything.  Since there aren't that many members who are using this panel script, can you PLEASE check with the forum of the creator of the script, dpeca.  Suggest that you register with his Forum first and then submit your inquiry to him:

https://forum.myvestacp.com/index.php

Also note that posts like these should not earn you any credit points. There is very little content in it (it is a one-liner post) and too little information to make sense to the membership of the Forum.
Terminal
Thank you to Post4VPS and VirMach for my awesome VPS 9!  
Reply
#15
(04-19-2021, 07:57 PM)deanhills Wrote:  @sagher  There isn't enough information in your inquiry to make sense for any one who isn't using the script.  It doesn't mean anything.  Since there aren't that many members who are using this panel script, can you PLEASE check with the forum of the creator of the script, dpeca.  Suggest that you register with his Forum first and then submit your inquiry to him:

https://forum.myvestacp.com/index.php

Also note that posts like these should not earn you any credit points.  There is very little content in it (it is a one-liner post) and too little information to make sense to the membership of the Forum.

@deanhills thanks for your kind reminder. i find out the issue with google helps and the link you gave me was much more for me. hence i still not got email for registration completion however i uninstall my vestaCP because the same thing i am facing which i notice in past. the CP is going to block all ports incoming outgoing, i add custom rules for iptable and also use ufw rules and after it i 75% succeed to open ports traffic but still too much congestion and traffic flow is dead. also many many ports are not work even i add them in accept list. 
after removing CP, all things works fine back. and it is again strange for me why it will be happened. 
Anyways when i will be free from work load i ll do check it again and remarks my feedback here.

Thankyou
Heart LOVE FOR ALL  HATRED FOR NONE Heart
Reply
#16
OK @sagher  that sounds like a really good plan.  Do you want me to reinstall the OS for you so that you are ready to start fresh again when you have time available?

To be honest, I think you've proved to yourself that the Debian Fork of VestaCP is not an easy script for the panel to install.  For example, if you check that support forum of dpeca's, you'll notice that he didn't really solve the issue with Let's Encrypt.  So maybe this script is not really meant for you to use with Debian as it is not that user-friendly.  I know I won't use it after your experience.  With my own experience, if and when I change from VestaCP I'll change to CyberPanel.  I'll probably start with a beginner installation like this one for CentOS 7.0:
https://www.beginnor.com/install-cyberpanel/

But if you are still interested in VestaCP, maybe you should try the VestaCP fork that @sohamb03 is using from Belgium instead.  @sohamb03 is quite knowledgeable about the most secure VestaCP scripts, and I'm sure he would have tried out your script as well.  But then you'll have to change your OS to CentOS 7.0.  As the fork from Belgium won't work with Debian - or if it does, it will probably come up with similar bugs to the ones you've already experienced with the Debian fork of dpeca's.
Terminal
Thank you to Post4VPS and VirMach for my awesome VPS 9!  
Reply
#17
(04-22-2021, 04:51 AM)deanhills Wrote:  But if you are still interested in VestaCP, maybe you should try the VestaCP fork that @sohamb03 is using from Belgium instead.  @sohamb03 is quite knowledgeable about the most secure VestaCP scripts, and I'm sure he would have tried out your script as well.  But then you'll have to change your OS to CentOS 7.0.  As the fork from Belgium won't work with Debian - or if it does, it will probably come up with similar bugs to the ones you've already experienced with the Debian fork of dpeca's.

Yep, the CentOS fork works absolutely fine. The author (who is a member of the original VestaCP dev team) has addressed all the issues in the panel including the Let's Encrypt issue and the security vulnerabilities which had been brought up earlier on the Vesta issues board. Here's the link to the panel - https://github.com/madeitbelgium/vesta ... it has clear-cut instructions for installation (only two commands in fact). Do remember that this panel wouldn't work in any way with Ubuntu/Debian. The installation script along with the source scripts which get pulled during the installation are written only for CentOS. 

If you still wanna stick with Debian, do not go for MyVestaCP ... agreed dpeca is an awesome developer maintaining that form, in my opinion, it is more developer-oriented and meant for users who can solve basic issues during installation and usage on their own. A good user-friendly alternative is HestiaCP ... it's a Vesta fork as well and meant only for Ubuntu/Debian and quite well maintained too. https://hestiacp.com/

Good luck!
Sayan Bhattacharyya,

Heartiest thanks to Post4VPS and Virmach for my wonderful VPS 9!
Reply
 


Possibly Related Threads...
Thread Author Replies Views Last Post
  VPS 18 - Lagging issues OldMeister 4 459 10-25-2020, 05:34 PM
Last Post: OldMeister
  CyberPanel Installing Error huuthi95 8 1,230 02-13-2020, 09:50 AM
Last Post: deanhills
  VPS 9 SELinux issues after upgrade to KVM deanhills 7 1,095 12-21-2019, 01:43 PM
Last Post: deanhills
  Problem installing some packages hamed 6 1,024 10-14-2019, 01:31 PM
Last Post: hamed
  Vps 13 Conectivity issues Decent12 3 2,281 11-06-2016, 03:14 PM
Last Post: TrK

Forum Jump:


Users browsing this thread: 1 Guest(s)

Sponsors: VirMach - Host4Fun - CubeData - Evolution-Host - HostDare - Hyper Expert - Shadow Hosting - Bladenode - Hostlease - RackNerd - ReadyDedis - Limitless Hosting


About Post4VPS

Post4VPS is a forum/destiny where you can Delploy Your Free VPSs just by the Power of Posts.

We Provide VPSs of many locations like Germany,US,Canada,France,London,etc.

We also Provide VPSs of Both Linux and Windows OS.