Problems activating your account? Send notification email to: admin@post4vps.com
Host4Fun Budget VPS Hosting

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Some packages problem Debian
#1
Hello Friends, 
                      Everyone knows that i have won a new VPS today from our community.I am trying to start a gaming-server application but whenever i run the command to start the server it shows errors.

failed: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by plugin )
failed: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by plugin )
/usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by plugin )
I searched on google for the solution but did not understand the problem so asking here.
It also shows a error during update
W: Failed to fetch http://ftp.debian.org/debian/dists/jessie-updates/InRelease  Unable to find expected entry 'main/binary-amd64/Packages' in Release file (Wrong sources.list entry or malformed file)

E: Some index files failed to download. They have been ignored, or old ones used instead.

Thanks to Post4VPS and Sponsors for their great services.          Heart HostLease is Best Heart
#2
Error No. #1

Try this:
apt-get install build-essential

After that try to start the game server application again.


Error No. #2:

The repository "jessie-updates" no longer exists since Debian Jessie has been moved to "oldstable" status. Feel free to post the content of /etc/apt/sources.list and I will help you to get rid of the second error.

Or see this post: https://post4vps.com/Thread-apt-get-upda...8#pid26388
#3
(07-05-2019, 12:47 PM)Hidden Refuge Wrote:  Error No. #1

Try this:
apt-get install build-essential

After that try to start the game server application again.
I have install this but still server is showing same error.I have read the instructions you gave me but tried only the first one.Currently due to some electricity problem i shall try remaining after a couple of hours. Replying you now to inform about what i tried.
I am sorry for posting less information as i always.


EDIT
This is the data in /etc/apt/source.list.
deb http://ftp.debian.org/debian jessie main contrib non-free
deb http://ftp.debian.org/debian jessie-updates main contrib non-free
deb http://security.debian.org jessie/updates main contrib non-free

update problem has been solved with the method you gave.But still have those problems in plugins load.I replaced source.list data with the following

deb http://deb.debian.org/debian/ oldstable main contrib non-free
deb-src http://deb.debian.org/debian/ oldstable main contrib non-free

deb http://deb.debian.org/debian-security oldstable/updates main
deb-src http://deb.debian.org/debian-security oldstable/updates main

Thanks to Post4VPS and Sponsors for their great services.          Heart HostLease is Best Heart
#4
i am very curious if error 1 is solved for you after installing build essentials. Cause it didn't in my case. Though that was another software i was trying to run. It took creating softlink (or preloading the .so) in my case.

I guess you could also just upgrade to stretch. be careful with editing the source file if you decide to do that though.

edit. i guessed it would remain. haha

the error no 1.

Just link the system .so file to the path in the directory of the software. use find to locate them.
Sincere Thanks to Shadow Hosting and post4vps  for my awesome vps4. Also a big thanks to cubedata for the great experience on my previous vps, vps8.
#5
(07-05-2019, 01:47 PM)rudra Wrote:  i am very curious if error 1 is solved for you after installing build essentials. Cause it didn't in my case. Though that was another software i was trying to run. It took creating softlink (or preloading the .so) in my case.

I guess you could also just upgrade to stretch. be careful with editing the source file if you decide to do that though.

edit. i guessed it would remain. haha

the error no 1.

Just link the system .so file to the path in the directory of the software. use find to locate them.

Do you mean that file "system.so" should be in the server/file directory or in the plugins directory which were failed? May i include this plugin in program configuration for load or not?
Let me try this if it solves my problem.I shall try copying it one by one in both program directory and plugins directory which are not loading.

Thanks to Post4VPS and Sponsors for their great services.          Heart HostLease is Best Heart
#6
@Rehan
it is not system.so
i mean routine library (.so files) that is in the system path. you will find the required files in the error messages.

let me reach home first. i will edit this and add more info.
Sincere Thanks to Shadow Hosting and post4vps  for my awesome vps4. Also a big thanks to cubedata for the great experience on my previous vps, vps8.
#7
Glad to hear that problem #2 is solved now Smile .


Regarding error #1. It looks like the error is very common on Debian 8 when trying to use recent software (all kinds of different software). It is related to the outdated version of gcc in Debian 8 (see here for a reference). Latest gcc on Debian 8 is "gcc (Debian 4.9.2-10+deb8u2) 4.9.2" and your application probably needs a higher version.

Option 1: Try this suggestion to fix the issue. This is most likely what rudra meant with loading the libraries into the system path.

Option 2: Upgrade to Debian Stretch (link). NOT RECOMMENDED ON OpenVZ VPSs!
#8
(07-05-2019, 07:15 PM)Hidden Refuge Wrote:  Glad to hear that problem #2 is solved now Smile .


Regarding error #1. It looks like the error is very common on Debian 8 when trying to use recent software (all kinds of different software). It is related to the outdated version of gcc in Debian 8 (see here for a reference). Latest gcc on Debian 8 is "gcc (Debian 4.9.2-10+deb8u2) 4.9.2" and your application probably needs a higher version.

Option 1: Try this suggestion to fix the issue. This is most likely what rudra meant with loading the libraries into the system path.

Option 2: Upgrade to Debian Stretch (link). NOT RECOMMENDED ON OpenVZ VPSs!

Well, i didn't understand what rudra is saying about.The link you gave me is expired or invalid. they are showing page not found.As you know that i have VPS9 and it is OpenVZ so should i try the Option two or not?
Well asking another question that Ubuntu on VPS9 is Ubuntu 16.04 x86_64. What if i update it manually from terminal to Ubuntu 18 ?
Actually i was facing problems in cmd " reboot " after update & upgrade. as a couple of months ago i asked about it.Maybe upgrading to ubuntu 18 will solve that error.
So what you say?

Thanks to Post4VPS and Sponsors for their great services.          Heart HostLease is Best Heart
#9
upgrading is probably the best option . it not only have a chance to 'fix' the problem but you also get support from debian because older version will be unsupported and will not receive any update which is important . even though linux dont get virueses as easy as windows it is still important to get it up to date espescially that updating is free unlike windows that updating on free version i mean cracked version cause it to be unactivated
Terminal
humanpuff69@FPAX:~$ Thanks To Shadow Hosting And Post4VPS for VPS 5
#10
Sorry about the issue with the link. It should have worked as it was the direct share link to a post but somehow it didn't.

*scratching head* Duh.

Try the following one instead https://stackoverflow.com/a/20357035 or this one https://stackoverflow.com/questions/2035...-not-found (go to the second post that is marked as the solution). Both are two different links to the post with the answer to the same issue but with a different application.



I believe that you cannot upgrade to either Debian 9, Ubuntu 18 or anything newer on OpenVZ. The OpenVZ kernel is so old that it has become widely incompatible with the base of modern Linux distributions such as gcc/libc and other packages that are the real foundation of the distribution together with the kernel.

You can attempt to perform a dist-upgrade from Debian 8 to 9 or from Ubuntu 16 to 18 but I still don't recommend it. Prepare to request a reinstallation of your VPS. It will most likely not work after performing the dist-upgrade.

There are NO OFFICIAL Debian 9, Ubuntu 17 or Ubuntu 18 templates for OpenVZ legacy because these OSs are not compatible! So if I were you I wouldn't attempt to do a dist-upgrade. Having no official OS template for OpenVZ legacy speaks a lot for itself. See here for a list of official OSs for OpenVZ legacy: https://wiki.openvz.org/Download/template/precreated

In fact, this year (Nov 2019) OpenVZ legacy (OpenVZ based on RHEL 6 with 2.6.32 kernel) is reaching its EOL status (End of Life). This means no support, no updates and no further development of OpenVZ legacy. So no newer OSs will be working on OpenVZ 6! No new Debian, Ubuntu, CentOS or other Linux distributions. See here for OpenVZ lifecycle and support status: https://wiki.openvz.org/Releases


I admit it is sad to say but owning and still selling OpenVZ legacy VPSs in 2019 is a sad and irresponsible thing. The technology is simply obsolete. Despite the fact that the 2.6.32 kernel for OpenVZ has been updated and developed it is still far far behind nowadays kernels. And it is impossible to merge all the features into such an old kernel.


CentOS 7 is a official OpenVZ legacy distribution. Maybe you can try it? It is still the latest OpenVZ version that receives support by the CentOS community and RHEL.
 


Possibly Related Threads...
Thread Author Replies Views Last Post
  Problem installing some packages hamed 6 148 10-14-2019, 01:31 PM
Last Post: hamed
  Port Forwarding Problem - Public port to Private Port chanalku91 10 266 09-17-2019, 04:56 PM
Last Post: Hidden Refuge
  iptables problem solving chanalku91 8 356 07-28-2019, 03:51 AM
Last Post: deanhills
  direct admin login problem hamed 6 274 07-21-2019, 10:21 AM
Last Post: hamed
  Open game panel problem youssefbasha 18 1,062 04-28-2019, 11:51 AM
Last Post: youssefbasha

Forum Jump:


Users browsing this thread: 1 Guest(s)

Sponsors: VirMach - Host4Fun - CubeData - Evolution-Host - HostDare - SSDBlaze - VPSlices - Abc-Hosters - Hyper Expert - Shadow Hosting - Bladenode - HostDoc - Hostlease


About Post4VPS

Post4VPS is a forum/destiny where you can Delploy Your Free VPSs just by the Power of Posts.

We Provide VPSs of many locations like Germany,US,Canada,France,London,etc.

We also Provide VPSs of Both Linux and Windows OS.