Problems activating your account? Send notification email to: admin@post4vps.com
Host4Fun Budget VPS Hosting
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Point IP to Show Specific Domain with Cyberpanel
#1
Hello all,

I just installed Cyberpanel with my new VPS 13 Singapore location. Everything works very well, but I notice one problem. My IP shows 404 Not Found. This issue didn't appear while I use VestaCP as my panel. I don't know how to configure my IP to show my domain name.

I wanted to put my IP to show my website as if a visitor opens 1.1.1.1, they will see Cloudflare's DNS website. So, I wanted to configure my IP to show my website. How can I do that with Cyberpanel? My Cyberpanel uses OpenLiteSpeed.

Thanks for your help!
Thanks to HostDoc and Post4VPS for providing me excellent VPS 13!
Give me questions I can't answer not answers I can't question. - Richard Feynman
#2
Someone else faced this problem too. Here is the solution they've pointed out.

Quote:speedy200man
November 2018
I have found a way to do it. The steps are:
1. Go to openlitespeed admin page (:7080), go to Virtual Hosts and add a new vhost.
2. Fill in these details:
Virtual Host Name: *
Virtual Host Root: /home/default (or any folder you want)
Config File: $SERVER_ROOT/conf/vhosts/defaultvh/vhconf.conf
Folow Symbolik Link, Enable Scripts, Restrained - all set to yes.
3. Add the vhost, then click the view button and go to General tab.
4. Click on the pencil icon to edit the first group, and set the following:
Document Root: /home/default (or the folder you defined on the previous step)
Domain Name: *
5. Click on save and then do a graceful restart using the icon on the top.
6. Go to Listeners, click on the view icon from the Default, port 80 line.
7. On Virtual Host Mappings, add a new one, choosing * as virtual host type * on Domains.
8. Do a graceful restart of LSWS.
9. Place the files (html, images, etc.) in the Document Root defined earlier.
10. Enjoy!

ps: if you still get a 404 error page, run this command:
chown -R nobody:nobody /home/default

Credits:- https://forums.cyberpanel.net/discussion...o-404-page
#3
(07-12-2019, 01:13 PM)Manal Wrote:  Someone else faced this problem too. Here is the solution they've pointed out.


Credits:- https://forums.cyberpanel.net/discussion...o-404-page

I have no idea, already followed the trick, didn't work. Still it's 404 error not found when I open the IP.

Already did about 2-3 times actually, haha.
Thanks to HostDoc and Post4VPS for providing me excellent VPS 13!
Give me questions I can't answer not answers I can't question. - Richard Feynman
#4
(07-12-2019, 02:02 PM)tiwil Wrote:  I have no idea, already followed the trick, didn't work. Still it's 404 error not found when I open the IP.

Already did about 2-3 times actually, haha.

Did you try to reboot? (Sorry, a noob reply but that's what I forget mostly after applying the solution).
#5
@tiwil  Did you ask Cyberpanel about the problem?  Like I think your solution should be there.  

Does Cyberpanel have a discussion forum?  I found this discussion so far.  I'm sure you'll find more:
https://forums.cyberpanel.net/discussion...ns-problem
https://forums.cyberpanel.net/discussion...r-creation
[Image: 4ax8Kok.png]
Thank you to Post4VPS and VirMach for my super fast VPS 9!
- DH Blog




#6
(07-12-2019, 02:29 PM)Manal Wrote:  Did you try to reboot? (Sorry, a noob reply but that's what I forget mostly after applying the solution).

Oh.. Wow. You did it! Thanks for the quick "noob" solution! Hahaha.

I rebooted it when you ask me to reboot, now it works! Completely works! Thanks for the idea.
(07-12-2019, 02:32 PM)deanhills Wrote:  @tiwil  Did you ask Cyberpanel about the problem?  Like I think your solution should be there.  

Does Cyberpanel have a discussion forum?  I found this discussion so far.  I'm sure you'll find more:
https://forums.cyberpanel.net/discussion...ns-problem
https://forums.cyberpanel.net/discussion...r-creation

I did ask Google to ask Cyberpanel how they solve this problem, no result. My keyword seems doesn't too accurate when I search on Google. Manal found the solution! Thanks to @Manal.

Anyway, no offense, that's not what I actually mean, Dean. I mean, if you use VestaCP, and you open your IP address in the browser (without port), you will see your website there, right? So, this problem is where I got one, Cyberpanel didn't do that automatically for me, and I never get a result on how to do that.

Anyway, as Manal already solve and give a solution, thanks again @Manal, this thread actually can be closed now.
Thanks to HostDoc and Post4VPS for providing me excellent VPS 13!
Give me questions I can't answer not answers I can't question. - Richard Feynman
 


Possibly Related Threads...
Thread Author Replies Views Last Post
  CyberPanel FTP is not connecting youssefbasha 4 90 06-16-2019, 06:50 PM
Last Post: Hidden Refuge
  Domain Name not works sagher 6 969 06-22-2018, 07:19 PM
Last Post: sagher
  Can I use a sub domain on VPS meetdilip 14 8,412 08-31-2016, 02:27 PM
Last Post: TrK

Forum Jump:


Users browsing this thread: 1 Guest(s)

Sponsors: VirMach - Host4Fun - CubeData - Evolution-Host - HostDare - SSDBlaze - VPSlices - Abc-Hosters - Hyper Expert - Shadow Hosting - Bladenode - HostDoc - Hostlease


About Post4VPS

Post4VPS is a forum/destiny where you can Delploy Your Free VPSs just by the Power of Posts.

We Provide VPSs of many locations like Germany,US,Canada,France,London,etc.

We also Provide VPSs of Both Linux and Windows OS.